Pi 4 sudo apt-get update error

apt-get -update testing to secure

E: Repository ‘http://raspbian.raspberrypi.org/raspbian buster InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘stable’
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

This error in updating your Pi 4 is due to Buster, the current release of Raspbian, is now in Stable version.

It is a simple fix, phewww.

Instead of the usual

sudo apt-get update

run this instead

sudo apt update -y

if you get asked type “y”

This will update you list of available upgrades

Now you can run

sudo apt-get upgrade

as per normal

You might also want to upgrade the Pi4 using

sudo rpi-update before hand

davecarrera

Share

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: